怎么写出追击反转的红柱选股公式

2024-06-16 07:15

1. 怎么写出追击反转的红柱选股公式

1、公式源码如下:n:=2;
value:ref(every(closeref(close,1);
这是K线反转,如果是指标反转,将CLOSE替换成指标引用的值即可;
2、N值自行调整,表示连跌了多少天;

通达信股票软件追击反转指标选股里的条件设置:
首先要知道等于或大于或小于的值是多少,比如大于80就选取,然后,点加入条件,再次,选取其它指标,重复上述操作后,点执行选股即可。
追击反转指标选股公式如下:
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(VAR3*10,3);
VAR5:=LLV(LOW,13);
VAR6:=HHV(VAR4,13);
VAR7:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618;
VAR8:=IF(VAR7>500,500,VAR7);
STICKLINE(VAR8>-120,0,VAR8,3,1),COLORGRAY;
STICKLINE(VAR8>1 AND "KDJ.J">REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2),0,VAR8,3,0),COLORRED;
STICKLINE(VAR8>0.1 AND VAR8REF("KDJ.J",1) AND REF("KDJ.J",1)<REF("KDJ.J",2),0,VAR8,3,0),COLOR00FFFF;

怎么写出追击反转的红柱选股公式

2. 求高手帮忙将通达信一个指标公式改写成条件选股公式以及预警条件(提示突袭和全仓杀各一个)感激不尽!

F:=100*(C-REF(C,1))/REF(C,1); 
今小昨:=IF(C<REF(O,1) AND F<0,1,0); 
S1:=今小昨; 
今小前:=IF(C<REF(O,2) AND F<0,1,0); 
S2:=今小前; 
A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1));
全仓杀:A3;

突袭:ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG(3,6),2);
{两个选股全是用未来函数选的,建议谨慎使用,只可用做辅助}

3. (求高手帮我把一个指标公式改写成条件选股公式和条件预警公式(突袭和全仓杀提示各一个),感激不尽!

F:=100*(C-REF(C,1))/REF(C,1); 
今小昨:=IF(C<REF(O,1) AND F<0,1,0); 
S1:=今小昨; 
今小前:=IF(C<REF(O,2) AND F<0,1,0),LINETHICK0; 
S2:=今小前; 
A3:=S1=0 AND REF(S1,1)=1 AND S2=0 AND REF(S2,1)=1 AND CROSS(ZIG(3,10) ,REF(ZIG(3 ,10),1));
全仓杀入:A3=1;


智勇出击: ZIG(3,6)>REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG(3,6),2);
突袭:智勇出击=1;

(求高手帮我把一个指标公式改写成条件选股公式和条件预警公式(突袭和全仓杀提示各一个),感激不尽!

4. 跪求高手帮忙编写通达信的选股公式及预警公式 下面2个条件组合一个:

PN1:=DYNAINFO(8)>0;PN2:=DYNAINFO(17)>0;PN3:=DYNAINFO(22)>0;PN4:=DYNAINFO(23)>0;ST:=IF(NAMELIKE('ST')=1,0,IF(NAMELIKE('S
ST')=1,0,IF(NAMELIKE('*ST')=1,0,1)));
去除:=
PN1*PN2*PN3*PN4*ST;
{只选非ST类和当天非
停牌
的股------用于配合选股公式};
LC:=REF(CLOSE,1);SG:=EMA(HHV(HIGH,1),8);X1:=EMA(CLOSE,8);X30:=((X1
<
REF(X1,1))
AND
(CLOSE
<
X1));X31:=IF(((SG
<
REF(SG,1))
OR
X30),1,0);操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100,COLORRED,LINETHICK2;
震仓
线:=45,COLORMAGENTA;抄底线:=20,COLORGREEN;PP:=操作线<震仓线
AND
REF(操作线,1)>震仓线
;PP3:=操作线<抄底线
AND
REF(操作线,1)>抄底线;抓牛:=(((((COUNT((X31
=
1),4)
=
3)
AND
(X31
=
0))AND
O
0.085))*89)
>=89)OR((C-REF(C,1))/REF(C,1)>0.085
AND
(REF(PP3,1)
OR
REF(PP,1)))
;去除*抓牛;

5. 公式编写通达信 做一个预警和选股公式 两个 谢谢

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIF,9);MACD:=(DIF-DEA)*2;T1:=(MACD>0 AND MACD>=REF(MACD,1)) OR (MACDMA(C,25);

没看懂你的选股思路,这样的选股条件应该结果特别多.选股公式和预警公式是一样的.

公式编写通达信 做一个预警和选股公式 两个 谢谢

6. 求大师编写一个选股公式,同时有预警公能,自动弹出。

能自动弹出预警,这需要特定的软件。如全推行情的文华,大智慧等。
通达信行情软件是无法做到全市场监控预警的。
有人说可以,通达信里的确有这个功能提示,但实际上,那玩意就是个摆设。
另外,题目的条件描述不清,无法量化成公式。请将各种条件尽量描述清楚。
如相对低位,每个人心中的相对低位都不一样,题主的标准是?
一段时间内,究竟多长时间?小陪阳,涨幅多少范围?等等。

7. 急急请高手帮忙 组合通达信的选股公式和预警公式 (机会难得 去)

VAR1B:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1C:=EMA(VAR1B,21);
VAR1D:=(VAR1B-VAR1C)*10;
VAR1F:=POW(VAR1D,3)*0.1+POW(VAR1D,2);
逃顶:=IF(VAR1D>0.015,VAR1F,0)/450;
VV:=(HIGH+OPEN+LOW+CLOSE)/4;
VMA5:=MA(VV,5);
VMA10:=MA(VV,10);
VMA20:=MA(VV,20);
VMA250:=MA(VV,250);
角10度A:=((ATAN((MA(VMA5,3)/REF(MA(VMA5,3),1)-1)*100)*180/3.14115926)>=40);
A11角度A:=REF(角10度A=0,1) AND 角10度A=1;

角5度A:=((ATAN((MA(VMA10,2)/REF(MA(VMA10,2),1)-1)*100)*180/3.14115926)>=30);
A21角度A:=REF(角5度A=0,1) AND 角5度A=1;
均线开花:=(VMA5>=VMA10  AND COUNT(A11角度A,5) AND  COUNT(A21角度A,3)
AND VMA20>=REF(VMA20,1) AND C>VMA250);
VOL1:=VOL;
V5:=MA(VOL1,5),COLORWHITE;
V10:=MA(VOL1,20),COLORGREEN;
V20:=MA(VOL1,60),COLORYELLOW;
量5日:=((ATAN((MA(V5,5)/REF(MA(V5,5),1)-1)*100)*180/3.14115926)>=80);
量5日角度:=REF(量5日=0,1) AND 量5日=1;
量10日:=((ATAN((MA(V10,3)/REF(MA(V10,3),1)-1)*100)*180/3.14115926)>=80);
量10日角度:=REF(量10日=0,1) AND 量10日=1;
量线开花:=(V5>V10  AND COUNT(量5日角度,3) AND  COUNT(量10日角度,3)
AND V20>=REF(V20,1));
均线量线:=均线开花 OR 量线开花;
A11:=DMA(C, V/CAPITAL);
A21:=EMA(A11,5);
A31:=EMA(A21,10);
角10度:=((ATAN((MA(A11,3)/REF(MA(A11,3),1)-1)*100)*180/3.14115926)>=15);
A11角度:=REF(角10度=0,1) AND 角10度=1;
角5度:=((ATAN((MA(A21,2)/REF(MA(A21,2),1)-1)*100)*180/3.14115926)>=13);
A21角度:=REF(角5度=0,1) AND 角5度=1;
筹码峰开花:=(A11>A21 AND A21>A31 AND COUNT(A11角度,2) AND A21角度 AND A31>=REF(A31,1));
主升:=(逃顶/REF(逃顶,1)>=1),COLORYELLOW;
幅度10日:=(HHV(C,10)/LLV(C,10)<1.15)*0.25;
幅度15日:=(HHV(C,15)/LLV(C,15)<1.15)*0.35;
幅度20日:=(HHV(C,20)/LLV(C,20)<1.15)*0.45;
幅度60日:=(HHV(C,60)/LLV(C,60)<1.2)*0.55;
幅度120日:=(HHV(C,120)/LLV(C,120)<1.4)*0.75;
幅度250日:=(HHV(C,250)/LLV(C,250)<1.45)*0.95;
YDSR3:=(REF(幅度20日=0.45,1) AND 幅度20日=0);
YDSR4:=(REF(幅度60日=0.55,1) AND 幅度60日=0);
YDSR5:=(REF(幅度120日=0.75,1) AND 幅度120日=0);
YDSR6:=(REF(幅度250日=0.95,1) AND 幅度250日=0);
大牛:=(YDSR5 OR YDSR6 OR YDSR3 OR YDSR4);
新高:=(C>REF(HHV(C,250),1));
评分:=均线量线+筹码峰开花+主升+大牛+新高;
机会难得:=FILTER(评分>=3,5);

PN1:=DYNAINFO(8)>0;
PN2:=DYNAINFO(17)>0;
PN3:=DYNAINFO(22)>0;
PN4:=DYNAINFO(23)>0;
ST:=IF(NAMELIKE('ST')=1,0,
IF(NAMELIKE('S ST')=1,0,
IF(NAMELIKE('*ST')=1,0,1)));
去除:=PN1*PN2*PN3*PN4*ST; 
 
机会难得 AND 去除;

急急请高手帮忙 组合通达信的选股公式和预警公式 (机会难得 去)

8. 高手有一个公式指标:怎样能改写成条件选股公式,和条件预警公式。急急急

F:=100*(C-REF(C,1))/REF(C,1); 今小昨:=IF(CREF(ZIG(3,6),1)AND REF(ZIG(3,6),1)<REF(ZIG(3,6),2); 突袭:智勇出击=1;
o
最新文章
热门文章
推荐阅读